Uploaded image for project: 'Pax Wicket'
  1. PAXWICKET-490

Creating an assembly fails on missing feature aries-annotation which is no longer part of Karaf 4.2.2 (standard or enterprise)

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 5.0.0
    • Fix Version/s: None
    • Component/s: karaf
    • Labels:
      None
    • Environment:
      Karaf 4.2.2
      Pax Wicket 5.0.0

      OS Ubuntu Linux 18.04
      Java OpenJDK 1.8.0_191
    • Sprint:

      Description

      While upgrading an existing application I ran into issues in getting my wicket app to run again.

      While trying to sort out what is causing my issues I reverted to an example project I created a few year ago. While trying to upgrade it to the latest Karaf, Wicket and Pax Wicket I ran into problems as well. I get the following error when trying to build a Karaf assembly:

      ERROR Failed to execute goal org.apache.karaf.tooling:karaf-maven-plugin:4.2.2:assembly (default-assembly) on project wk-assembly: Unable to build assembly: Could not find matching feature for aries-annotation/0.0.0 -> Help 1

      This feature appears to no longer be part of Karaf 4.2.2 (standard and enterprise). It can however be fixed by adding the missing feature to my own feature file (see commit 2c02d6f).

      To me this seems like a hack, however I am wondering whether this feature is still a required depencency?

      When adding this feature I run in to runtime issues for which I have already created PAXWICKET-489 Open

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              misl Minto van der Sluis
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: