Details

    • Type: New Feature
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: 7.3.0
    • Component/s: None
    • Labels:
      None
    • Sprint:

      Description

      Just as we don't have pax-web-jetty8, pax-web-jetty9, ... I want to upgrade pax-web-undertow to use Undertow 2.0.x.

      The difficulty is that Undertow 2.0.x is already JavaEE 8 / Servlet API 4. So good time to upgrade to Tomcat 9 as well. However there's no yet Jetty 10.0.x...

      I also don't know yet about the target pax-web version. Switching to servlet-api-4 could be justification to upgrade in pax-web 8, but the current theme of pax-web8 is OSGi Enterprise R7 HTTP Service (and Whiteboard and JAX-RS) specification.

        Attachments

          Issue links

            Activity

              People

              • Assignee:
                ggrzybek Grzegorz Grzybek
                Reporter:
                ggrzybek Grzegorz Grzybek
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: