Uploaded image for project: 'Pax Runner'
  1. Pax Runner
  2. PAXRUNNER-399

Provision bundles from reference: URLs

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.7.4
    • Fix Version/s: 1.7.5
    • Component/s: provisioning
    • Labels:
      None

      Description

      Pax Runner shall be able to provision bundles from reference: URLs supported by the new pax-url-reference module, see PAXURL-137.

      This protocol is supported by Equinox and Felix, though not an OSGi standard.

      Bundles from reference URLs shall not be downloaded to the provisioning area. They shall be provisioned in place from a file: URL wrapped in the reference: URL.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              hwellmann Harald Wellmann added a comment -
              • new dependency on pax-url-reference
              • PAX URL versions changed to 1.3.5-SNAPSHOT
              • added reference: handler to runner properties
              • never download bundles with reference: URLs

              https://github.com/ops4j/org.ops4j.pax.runner/commit/ffa4813905c9e67632d3a9f14e9c58c47a575287

              tonit Toni Menzel added a comment -

              Harald, is there a way to not use reference urls (e.g. revert to the old behaviour where bundles are downloaded and referenced from within runner/bundles cache ) ?

              hwellmann Harald Wellmann added a comment -

              If you don't use reference URLs, you get the old behaviour - Pax Runner does not convert other URLs to reference URLs automatically.

              tonit Toni Menzel added a comment -

              hmm.. actually i was investigating http://team.ops4j.org/browse/PAXRUNNER-405 . Since it broke for them in 1.7.5 i see some relationship. Though i have not been able to reproduced the issue.


                People

                • Assignee:
                  hwellmann Harald Wellmann
                  Reporter:
                  hwellmann Harald Wellmann
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Development