Do not provision OSGi Alliance Compendium bundle automatically

Description

Right from the beginning Pax Runner provisioned the OSGi compendium bundle automatically into the started framework. The problem is that it provisions a certain version like 4.1 lately, and next it should go to 4.2 and this could interfere with what user wants.

What I want to do is to not provision that bundle anymore and let the user decide if he wants it or not. And if he does then he can decide the version.

So, a simple solution is to create profiles for all versions of compendium and then user will just have to specify:

This I think is a good middle ground. Easy to use and flexible.

Environment

None

Assignee

Alin Dreghiciu

Reporter

Alin Dreghiciu

Labels

None

Fix versions

Priority

Major
Configure