Uploaded image for project: 'Pax LDAP Server'
  1. Pax LDAP Server
  2. PAXLDAP-2

Requires manual intervention to start the services

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 0.2.0
    • Fix Version/s: 0.2.0
    • Component/s: Apache DS
    • Labels:
      None

      Description

      After issuing 'pax-run' command the flow halts after starting the framework bundle(as in 1.jpg) and requires a 'Carriage return' key to be pressed to continue so that it starts the Pax LDAP server (as in 2.jpg)

        Gliffy Diagrams

          Attachments

            Activity

            rijoyr Rijoy R created issue -
            mkuespert Matthias Küspert added a comment -

            Rijoy,

            some questions:

            1. does this only happen on Windows?

            2. do you use the provided runner.args? If not, please also attach the one you use.

            3. which LDAPServer version are you using? Last Monday I released a 0.2.0 version which now also contains a ready-to-use assembly (see http://repository.ops4j.org/mvn-releases/org/ops4j/pax/ldapserver/assemblies/pax-ldapserver-demo-apacheds/0.2.0/). Does this assembly have that problem too?

            /Matthias

            rijoyr Rijoy R added a comment -

            1 -> not sure if it happens on other platforms, I have used it only on Windows
            2 -> I do use the provided runner.args
            3 -> previously used version 0.0.1-Snapshot, now tried with 0.2.0 and the problem persists.

            mkuespert Matthias Küspert added a comment -

            I could not reproduce this behaviour, neither in Windows XP, nor on my OS X 10.5.

            Please check if it's really a LDAPServer problem by disabling (using ##) or removing the last line (containing the pax-ldapserver-apacheds reference) from the runner.args.

            mkuespert Matthias Küspert added a comment -

            Updated affected version

            mkuespert Matthias Küspert made changes -
            Field Original Value New Value
            Affects Version/s 0.2.0 [ 10372 ]
            rijoyr Rijoy R added a comment -

            Yes Mattias, the flow halts even after disabling the pax-ldapserver-apacheds reference, so the problem is something else isnt it...

            mkuespert Matthias Küspert added a comment -

            Yes it seems like this is not a LDAPServer problem, therfor I close this issue.

            To further test for the root of the problem I would suggest to start with an empty framework/runner.args) and then successively put in other bundles.

            mkuespert Matthias Küspert made changes -
            Fix Version/s 0.2.0 [ 10372 ]
            Resolution Cannot Reproduce [ 5 ]
            Status Open [ 1 ] Closed [ 6 ]

              People

              • Assignee:
                mkuespert Matthias Küspert
                Reporter:
                rijoyr Rijoy R
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development