Upgrade to Derby 10.14.2.0 and remove the pax-jdbc derby wrapper

Description

As Derby bundle now provides the DataSourceFactory, it's not required anymore to wrap in pax-jdbc.
It's actually causing an issue because, when using derby, we have two DataSourceFactory service registered (the one from the derby bundle and the one from pax-jdbc-derby bundle), so it means we have two datasources created for a single configuration.

Environment

None

Status

Assignee

Jean-Baptiste Onofre

Reporter

Jean-Baptiste Onofre

Labels

None

Fix versions

Affects versions

1.3.1
1.3.0
1.3.2

Priority

Major