We're updating the issue view to help you get more done. 

Improve version handling in KarafManipulatorFactory

Description

https://groups.google.com/d/msg/ops4j/Ic7J0XUNCLk/yLNAVGebDgAJ

It makes sense IMHO. Can you please create a Jira about that, I will improve the versioning management.

Thanks,
Regards
JB
On 10/12/2018 13:04, Martin Lichtin wrote:
> I'd like to to use Pax-Exam with a custom-built Karaf that uses a custom versioning.
> Problem is with this code here in KarafManipulatorFactory
>
> if (dots < 3) {
> version = new Version(karafVersion.replaceFirst("-", "."));
> }
>
> It fails if one provides a version such as "1.4-SNAPSHOT". It should not do this "replaceFirst".
>
> Also, is it possible to get rid of this code here?
>
> if (version.getMajor() < 2 || version.getMajor() == 2 && version.getMinor() < 2) {
> throw new IllegalArgumentException("Karaf versions < 2.2.0 are not supported");
> }
>

Environment

None

Status

Assignee

Unassigned

Reporter

Martin Lichtin

Labels

None

Affects versions

4.13.1

Priority

Minor