mvn pax:provision and pax:run doesn't can't find thing on same url that pax-run.sh script does.

Description

This is with running mvn pax:run (same thing happens with paxrovision)

fou164:lib wakko$ mvn pax:run
[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------ [INFO] Building SmsToEmailService-lib
[INFO] task-segment: [pax:run] (aggregator-style)
[INFO] ------------------------------------------------------------------------ [INFO] [pax:run {execution: default-cli}]
[INFO] snapshot org.coos.modules:SmsToEmailService-lib:1.0-SNAPSHOT: checking for updates from bjarne
[INFO] snapshot org.coos.modules:mailEdge-api:0.3-SNAPSHOT: checking for updates from bjarne
[INFO] snapshot org.coos.messaging:messaging-j2se:0.3-SNAPSHOT: checking for updates from bjarne
[INFO] Installing /Users/wakko/Documents/source/git/coos-internal/Components/SmsToEmailService/lib/runner/deploy-pom.xml to /Users/wakko/.m2/repository/org/coos/modules/SmsToEmailService-lib/build/deployment/1.0-SNAPSHOT/deployment-1.0-SNAPSHOT.pom
______ ________ __ __
/ __ / / __ / / / / /
/ ___/ / __ / _\ \ _/
/ / / / / / / \ \ // // // // /_/

Pax Runner (1.1.1) from OPS4J - http://www.ops4j.org
----------------------------------------------------
-> Using config [classpath:META-INF/runner.properties]
-> Using only arguments from command line
-> Scan bundles from /Users/wakko/Documents/source/git/coos-internal/Components/SmsToEmailService/lib/runner/deploy-pom.xml
-> Scan bundles from [scan-pom:file:/Users/wakko/Documents/source/git/coos-internal/Components/SmsToEmailService/lib/runner/deploy-pom.xml]
-> Scan bundles from [scan-composite:mvn:org.ops4j.pax.runner.profiles/messaging//composite]

___
/ /
/ / Oops, there has been a problem!
/ /
/__/ URL mvn:org.ops4j.pax.runner.profiles/messaging//composite could not be resolved.
___
/__/ Use --log=debug to see details.

This is with the script:

fou164:lib wakko$ pax-run.sh --profiles=messaging --platform=equinox
______ ________ __ __
/ __ / / __ / / / / /
/ ___/ / __ / _\ \ _/
/ / / / / / / \ \ // // // // /_/

Pax Runner (1.1.1) from OPS4J - http://www.ops4j.org
----------------------------------------------------
-> Using config [classpath:META-INF/runner.properties]
-> Using only arguments from command line
-> Scan bundles from [scan-composite:mvn:org.ops4j.pax.runner.profiles/messaging//composite]
-> Scan bundles from [scan-composite:mvn:org.ops4j.pax.runner.profiles/log//composite]
-> Scan bundles from [scan-bundle:mvn:org.ops4j.pax.logging/pax-logging-api/1.4]
-> Scan bundles from [scan-bundle:mvn:org.ops4j.pax.logging/pax-logging-service/1.4]
-> Scan bundles from [scan-bundle:mvn:org.apache.xmlbeans/org.coos.messaging.org.apache.xmlbeans/2.4.0]
-> Scan bundles from [scan-bundle:mvn:net.sourceforge.mx4j/com.springsource.mx4j/3.0.2]
-> Scan bundles from [scan-bundle:mvn:javax.xml.stream/com.springsource.javax.xml.stream/1.0.1]
-> Scan bundles from [scan-bundle:mvn:org.coos/helpers-j2se/4.6-SNAPSHOT]
-> Scan bundles from [scan-bundle:mvn:org.coos.messaging/messaging-j2se/0.3-SNAPSHOT]
-> Scan bundles from [scan-bundle:mvn:org.coos.api/coos-api/0.3-SNAPSHOT]
-> Scan bundles from [scan-bundle:mvn:org.coos.extender/coos-extender/0.3-SNAPSHOT]
-> Provision bundle mvn:org.ops4j.pax.logging/pax-logging-api/1.4, at default start level, bundle will be started, bundle will be loaded from the cache
-> Provision bundle mvn:org.ops4j.pax.logging/pax-logging-service/1.4, at default start level, bundle will be started, bundle will be loaded from the cache
-> Provision bundle mvn:org.apache.xmlbeans/org.coos.messaging.org.apache.xmlbeans/2.4.0, at default start level, bundle will be started, bundle will be loaded from the cache
-> Provision bundle mvn:net.sourceforge.mx4j/com.springsource.mx4j/3.0.2, at default start level, bundle will be started, bundle will be loaded from the cache
-> Provision bundle mvn:javax.xml.stream/com.springsource.javax.xml.stream/1.0.1, at default start level, bundle will be started, bundle will be loaded from the cache
-> Provision bundle mvn:org.coos/helpers-j2se/4.6-SNAPSHOT, at default start level, bundle will be started, bundle will be loaded from the cache
-> Provision bundle mvn:org.coos.messaging/messaging-j2se/0.3-SNAPSHOT, at default start level, bundle will be started, bundle will be loaded from the cache
-> Provision bundle mvn:org.coos.api/coos-api/0.3-SNAPSHOT, at default start level, bundle will be started, bundle will be loaded from the cache
-> Provision bundle mvn:org.coos.extender/coos-extender/0.3-SNAPSHOT, at default start level, bundle will be started, bundle will be loaded from the cache
-> Preparing framework [Equinox 3.5.0]
-> Downloading bundles...
-> Equinox 3.5.0 : 1122602 bytes @ [ 893kBps ]
-> Eclipse utilities : 22471 bytes @ [ 440kBps ]
-> Eclipse compendium services : 66065 bytes @ [ 388kBps ]
-> Using execution environment [J2SE-1.6]
-> Runner has successfully finished his job!

Environment

None

Activity

Show:
Alin Dreghiciu
August 19, 2009, 1:30 PM

The problem is known and has been discussed in issues like:
Can you try again? I synchronized maven 2 repo to pax runner profiles repo.

Assignee

Alin Dreghiciu

Reporter

Anders Storsveen

Labels

None

Affects versions

Priority

Major
Configure