Upgrade main JDK of CI Server to latest JDK6

Description

From Harald:
The CI builds are broken since the Pax URL upgrade from 1.4.0.RC1 to 1.4.0:
http://ci.ops4j.org/hudson/job/org.ops4j.pax.exam2/115/console

This seems to be due to a JDK bug, I remember a similar issue from Pax Wicket.

I can reproduce the issue locally compiling the 2.4.0 sources with JDK 1.6.0_26 (Linux 64 bit).

After downgrading the Pax URL dependency to 1.4.0.RC1, the problem disappears.

With 1.6.0_32 or 1.7.0_04, everything is fine.

So I think we should upgrade the JDK on the CI server.

Environment

None

Activity

Show:
Toni Menzel
May 23, 2012, 10:30 AM

new 1.6.0_32 is default

Harald Wellmann
May 23, 2012, 12:12 PM

Just had a look at the Hudson config pages: I don't see a JDK 6, and JDK 7 is the default.

Pax Exam is fine with JDK 7, but I don't think that's what you intended, or is it?

Assignee

Toni Menzel

Reporter

Toni Menzel

Labels

None

Priority

Major
Configure